Commit 87da251a by Geoff Simmons

Version 1.6.1, packages for VRT 8 (Varnish 6.1 & libvarnish.so.2).

parent 00961233
AC_PREREQ([2.68])
AC_INIT([libvmod-re2], [trunk], [varnish-support@uplex.de], [vmod-re2])
AC_INIT([libvmod-re2], [1.6.1], [varnish-support@uplex.de], [vmod-re2])
AC_COPYRIGHT([Copyright 2016-2017 UPLEX - Nils Goroll Systemoptimierung])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_AUX_DIR([build-aux])
......
......@@ -9,11 +9,12 @@ Group: System Environment/Daemons
URL: https://code.uplex.de/uplex-varnish/libvmod-re2
Source0: %{name}-%{version}.tar.gz
# varnish from varnish60 at packagecloud
Requires: varnish >= 6.0.0
# varnish from varnish61 at packagecloud
# This is the Requires for VMOD ABI compatibility with VRT >= 8.0.
Requires: varnishd(vrt)%{?_isa} >= 8
Requires: re2 >= 20150501
BuildRequires: varnish-devel >= 6.0.0
BuildRequires: varnish-devel >= 6.1.0
BuildRequires: re2-devel >= 20150501
BuildRequires: pkgconfig
BuildRequires: make
......@@ -74,3 +75,24 @@ rm -rf %{buildroot}
/sbin/ldconfig
%changelog
* Mon Dec 3 2018 Geoff Simmons <geoff@uplex.de> - 1.6.1
- True dependency on VRT 8.0, compatible with Varnish 6.1, libvarnishapi.so.2
* Fri Nov 30 2018 Geoff Simmons <geoff@uplex.de> - 1.5.2
- Strictly require Varnish 6.0 -- compatible with libvarnishapi.so.1
* Wed Oct 3 2018 Geoff Simmons <geoff@uplex.de> - 1.6.0
- Build for VRT 8.0 / Varnish 6.1.
* Wed Oct 3 2018 Geoff Simmons <geoff@uplex.de> - 1.5.1
- Require ABI compatibility -- also compatible with Varnish 6.0.1.
- RPM builds use make -j.
* Mon May 7 2018 Geoff Simmons <geoff@uplex.de> - 1.5.0
Bugfix -- off-by-one error in rewrites
* Sun Apr 1 2018 Geoff Simmons <geoff@uplex.de> - 1.4.4
Compatibility with Varnish 6.0.
* Tue Dec 19 2017 Geoff Simmons <geoff@uplex.de> - 1.4.3
Enforce ABI compatibility with VRT 6.0.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment