Commit 8e0615b3 by Geoff Simmons

RPM build is based on Varnish 6.1.

parent ed3c3acf
......@@ -10,8 +10,13 @@
# - this script (named pkg)
# - VMOD re2 tarball (vmod-re2-$VERSION.tar.gz)
# - RPM spec file (vmod-re2.spec)
# - yum repo config for varnish5@packagecloud (varnishcache_varnish5.repo)
# (see https://packagecloud.io/varnishcache/varnish5/install#manual-rpm)
# - yum repo config for varnish61@packagecloud (varnishcache_varnish61.repo)
# (see https://packagecloud.io/varnishcache/varnish61/install#manual-rpm)
# So this is a sample docker invocation:
#
# $ docker run -t -v $PWD:/srv -e VERSION=1.2.3 -e RELEASE=4711 \
# rpmbuild/centos7 /srv/pkg
# At the end of the run, binary, source and debuginfo RPMs are in the
# directory mounted to /srv.
......@@ -40,9 +45,9 @@ sudo yum install -y -q \
https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
# set up varnish repo
sudo cp /srv/varnishcache_varnish5.repo /etc/yum.repos.d/
sudo cp /srv/varnishcache_varnish61.repo /etc/yum.repos.d/
sudo yum -q makecache -y --disablerepo='*' --enablerepo='varnishcache_varnish5'
sudo yum -q makecache -y --disablerepo='*' --enablerepo='varnishcache_varnish61'
# build requirements
sudo yum install -y -q \
......
[varnishcache_varnish61]
name=varnishcache_varnish61
baseurl=https://packagecloud.io/varnishcache/varnish61/el/7/$basearch
repo_gpgcheck=1
gpgcheck=0
enabled=1
gpgkey=https://packagecloud.io/varnishcache/varnish61/gpgkey
sslverify=1
sslcacert=/etc/pki/tls/certs/ca-bundle.crt
metadata_expire=300
[varnishcache_varnish61-source]
name=varnishcache_varnish61-source
baseurl=https://packagecloud.io/varnishcache/varnish61/el/7/SRPMS
repo_gpgcheck=1
gpgcheck=0
enabled=1
gpgkey=https://packagecloud.io/varnishcache/varnish61/gpgkey
sslverify=1
sslcacert=/etc/pki/tls/certs/ca-bundle.crt
metadata_expire=300
......@@ -9,11 +9,11 @@ Group: System Environment/Daemons
URL: https://code.uplex.de/uplex-varnish/libvmod-re2
Source0: %{name}-%{version}.tar.gz
# varnish from varnish5 at packagecloud
Requires: varnish >= 5.2.0
# varnish from varnish60 at packagecloud
Requires: varnish >= 6.0.0
Requires: re2 >= 20150501
BuildRequires: varnish-devel >= 5.2.0
BuildRequires: varnish-devel >= 6.0.0
BuildRequires: re2-devel >= 20150501
BuildRequires: pkgconfig
BuildRequires: make
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment