...
 
Commits (2)
......@@ -1735,10 +1735,12 @@ since 2015-06-01 (through 2019-04-01 at the time of writing).
If the VMOD is built against versions of RE2 since 2017-12-01, it uses
a version of the set match operation that reports out-of-memory
conditions during a match. In that case, the VMOD is not compatible
with earlier versions of RE2. This is only a problem if the runtime
version of the library differs from the version against which the VMOD
was built. If you encounter this error, consider re-building the VMOD
conditions during a match. (Versions of RE2 since June 2019 no longer
have this error, but nevertheless the different internal call is used
for set matches.) In that case, the VMOD is not compatible with
earlier versions of RE2. This is only a problem if the runtime version
of the library differs from the version against which the VMOD was
built. If you encounter this error, consider re-building the VMOD
against the runtime version of RE2, or installing a newer version of
RE2.
......
This diff is collapsed.
......@@ -1434,10 +1434,12 @@ since 2015-06-01 (through 2019-04-01 at the time of writing).
If the VMOD is built against versions of RE2 since 2017-12-01, it uses
a version of the set match operation that reports out-of-memory
conditions during a match. In that case, the VMOD is not compatible
with earlier versions of RE2. This is only a problem if the runtime
version of the library differs from the version against which the VMOD
was built. If you encounter this error, consider re-building the VMOD
conditions during a match. (Versions of RE2 since June 2019 no longer
have this error, but nevertheless the different internal call is used
for set matches.) In that case, the VMOD is not compatible with
earlier versions of RE2. This is only a problem if the runtime version
of the library differs from the version against which the VMOD was
built. If you encounter this error, consider re-building the VMOD
against the runtime version of RE2, or installing a newer version of
RE2.
......