Commit dbfef04e by Nils Goroll

bye bye VARNISHSRC again :)

Ref: 90c4b74 discussion

	#varnish-hacking log:

(09:53:32) slink: dridi phk so is it really agreed policy that indeed we
return to installing all headers which $ABI strict vmods do/could
require?
(09:54:48) slink: and if yes, what is the purpose of having
cache_varnishd.h over only cache.h then?
(09:58:54) phk: slink, that was not the outcome I anticipated, but if
that is how it will work, then that is how it will work.
(09:59:26) phk: slink, the purpose is to allow people to write VMODs
which doesn't require recompilation everything
parent f257be22
Pipeline #431 skipped
......@@ -21,7 +21,7 @@ Command line
<prefix>/bin/dcs
Varnish VMOD (Varnish 3 and newer)
Varnish VMOD (Varnish 3 and later)
----------------------------------
VCL:
......@@ -179,11 +179,11 @@ To build the documentation
To build the varnish module (VMOD)
* For Varnish 4 and 5
* For Varnish 4 and later
A full installation of Varnish to be used with the VMOD.
* For Varnish 3 as well as varnish 6 and later:
* For Varnish 3:
The source tree of the Varnish version the VMOD is to be used
with. Varnish must have been configured and compiled in this source
......@@ -251,8 +251,8 @@ required:
(normally `/usr/local`) or in the prefix specified by the `--prefix`
argument to `configure`.
Building the varnish module (vmod) for Varnish 4 and 5
------------------------------------------------------
Building the varnish module (vmod) for Varnish 4 and higher
-----------------------------------------------------------
If varnish is installed in a standard directory, generic :ref:BUILDING
as explained above should also build the vmod.
......@@ -275,13 +275,6 @@ When building the vmod, an additional
step is recommended to run the bundled `varnishtest` tests.
Building the varnish module (vmod) for Varnish 6
------------------------------------------------
In addition to the instructions given before for Varnish 4 and 5, a
build against Varnish 6 needs access to the varnish source: the
`VARNISHSRC` variable needs to be set as documented for Varnish 3 below.
Building the varnish module (vmod) for Varnish 3
------------------------------------------------
......
......@@ -130,7 +130,7 @@ if test "x$VMODDIR" != x && test "x$VMOD_DIR" = x ; then
AC_MSG_FAILURE([VMODDIR is now called VMOD_DIR])
fi
AC_ARG_VAR([VARNISHSRC], [path to Varnish source (varnish3 / varnish6)])
AC_ARG_VAR([VARNISHSRC], [path to Varnish source (varnish3)])
m4_ifdef([VARNISH_VMOD_INCLUDES],
[
......@@ -185,24 +185,10 @@ m4_ifdef([VARNISH_VMOD_INCLUDES],
AC_MSG_ERROR([unsupported varnish varsion])
;;
esac
if test "x$VARNISH_VERSION" = "xtrunk" ||
test "x$VARNISH_VERSION" = "x6*" ; then
if test "x$VARNISHSRC" = x; then
AC_MSG_FAILURE([Varnish trunk / varnish 6 needs VARNISHSRC])
else
VARNISHSRC=`cd $VARNISHSRC && pwd`
AC_CHECK_FILE([$VARNISHSRC/bin/varnishd/common/common_param.h],[
VMOD_INCLUDES="$VMOD_INCLUDES -I$VARNISHSRC/bin/varnishd"
AC_SUBST([VMOD_INCLUDES])
],[
AC_MSG_FAILURE(
[Could not find $VARNISHSRC/bin/varnishd/common/common_param.h])
])
fi
elif test "x$VARNISHSRC" = x; then
if test "x$VARNISHSRC" = x; then
: # OK
else
AC_MSG_FAILURE([VARNISHSRC must only be set for varnish < 4 and > 6])
AC_MSG_FAILURE([VARNISHSRC must only be set for varnish < 4])
# continue in common else case
],[
AM_CONDITIONAL([HAVE_VARNISH_M4], [false])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment